Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spaced360 not charging
#1
I was using m y spaced360 at the weekend on the charging station and the red light was on, but after a shirt time it switched off and now doesn't appear to be charging.I saw the post on this forum about resetting the plug but after doing this nothing appears to be happening. I've checked charger and there is a 10v power output. So any other problems or has the battery in unit expired.
 Reply
#2
Hi Davidy,

How long did you leave the unit on charge? Was the battery definitely completely discharged? How long did you leave the charger disassembled?
Simon D
Orbitsound Staff

[Image: orbitsound-sig-logo.png]
 Reply
#3
Hi Simon, at least four hours disassembled and well over 12 hours on the charger. When it was working the end lights were on so I assumed it was charging. Get no response at all, even tried the +,- and power button reset. I've repeated the process again with additional hours included.
 Reply
#4
Hi Davidy,

Send the charger into me along with a return address so I can take a look.

65-69 East road N1 6Ah
Simon D
Orbitsound Staff

[Image: orbitsound-sig-logo.png]
 Reply
#5
(14-08-2018, 01:47 PM)Simon D Wrote: Hi Davidy,

Send the charger into me along with a return address so I can take a look.

65-69 East road N1 6Ah


Simon, thanks for that but I think it's the unit itself. I've checked with a multimeter and the charger is showing an output of approx 12v. Dont know if the battery has died completely or if theres a away to check without stripping it down. End of the day it was a joining gift from Sky so doesn't owe me anything.
 Reply
#6
Hi DavidY,

I think we need to take some personal details from you to help you further so I shall message you privately.
Simon D
Orbitsound Staff

[Image: orbitsound-sig-logo.png]
 Reply